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2 Erste Schritte

In diesem Kapitel werden Sie zum ersten Mal in direkten Kontakt mit
Eclipse und CDT treten. Zunächst werden die Konzepte von Eclipse be-
sprochen und allgemeine Hinweise über das Arbeiten mit der Benutzer-
oberfläche von Eclipse gegeben. Im zweiten Abschnitt geht es dann
gleich los: Sie werden ein kleines Projekt mit Eclipse und CDT erstellen
und alle essentiellen Stufen einer Implementationsphase durchlaufen.
Im weiteren Verlauf werden dann wieder allgemeine Eclipse-Features
besprochen. Dazu zählen das Hilfesystem, die Erweiterungsoptionen
und die von der Eclipse-Plattform angebotenen Möglichkeiten, das Be-
nutzerinterface den eigenen Bedürfnissen anzupassen.

2.1 Konzepte des Eclipse-Frameworks

Bevor wir mit dem ersten Beispiel beginnen können, werden in die-
sem Abschnitt zunächst einige Eclipse-spezifische Begriffe und Bedie-
nungselemente eingeführt. Leser, denen Eclipse bereits vertraut ist, kön-
nen diesen Abschnitt bedenkenlos überspringen und sich gleich Ab-
schnitt 2.2 zuwenden, in dem wir ein erstes C-Projekt erstellen und
dabei den Editor und den Debugger ein wenig kennenlernen.

2.1.1 Workspace

Ein Workspace, zu Deutsch Arbeitsbereich, gehört zu jeder gestarteten
Eclipse-Instanz. Er ist ein Ordner im Dateisystem, unter dem Projekte,
deren Einstellungen sowie die Einstellungen der Plattform abgelegt wer-
den. Der Zugriff auf den Workspace ist exklusiv, d.h., lediglich eine ge-
startete Eclipse-Instanz darf darauf zugreifen. Mehrere Eclipse-Instanz-
en können allerdings gestartet werden, wenn sie jeweils verschiedene
Workspace-Pfade benutzen.

Ist Eclipse einmal gestartet, so können Sie im Menü File > Switch
Workspace zu einem bereits eingerichten Workspace umschalten. Wenn
Sie wünschen, einen weiteren Workspace-Pfad einzurichten, dann wäh-
len Sie im selben Menü den Menüpunkt Other... aus. Daraufhin öffnet
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sich der schon bekannte Workspace-Selektor, mit dem Unterschied, dass
Sie in Copy Settings die Einstellungen des aktuellen Workspace mit in
den neuen übernehmen können.

Abb. 2-1

Der aus Eclipse

hervorgerufene

Workspace-Selektor

2.1.2 Ressourcen

Unter Ressourcen versteht man in der Eclipse-Terminologie all das, was
auf einem Dateisystem abgelegt wird. Neben Dateien und Ordnern gilt
das Projekt als eigenständiger Ressourcentyp. Die Organisation ist hier-
archisch. Projekte befinden sich auf der ersten Ebene. Projekte und Ord-
ner werden auch als Container bezeichnet und können Dateien und
weitere Ordner beinhalten. Dabei müssen Dateien und Verzeichnisse
eines Projektes nicht zwangsläufig auch physisch innerhalb des Projekt-
pfades abgelegt werden, sondern können sich als verknüpfte Ressource
(engl. linked resource) auch außerhalb davon aufhalten.

2.1.3 Eclipse-Workbench

Die Arbeitsschritte des Entwicklers werden in der Workbench reali-
siert. Eine Workbench, von der durchaus mehrere Instanzen geöffnet
sein können, ist ein Fenster mit einer Reihe verschiedenartiger Bereiche,
deren konkrete Anzahl und Anordnung sehr frei vom Benutzer gestal-
tet werden kann. Abbildung 2-2 zeigt eine dem Auslieferungszustand
ähnliche Aufteilung, wobei noch einige Projekte geöffnet sind. Wich-
tige Bedienelemente sind dort besonders hervorgehoben. Diese werden
in den folgenden Abschnitten beschrieben.

2.1.4 Menüleiste

Unter der Titelleiste des Fensters befindet sich die Pulldown-Menülei-
ste, über die die möglichen Kommandos ausgeführt werden können, die
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Abb. 2-2

Die Eclipse-Workbench

dann irgendeine Veränderung hervorrufen. Etwas größer ist die Menü-
zeile in Abbildung 2-3 dargestellt. Deren Aufbau hält sich im Grunde
an die Konventionen für Benutzeroberflächen. Im File-Menü befinden
sich Aktionen, um Dateien zu öffnen, zu sichern und so weiter. Im Edit-
Menü befinden sich typische Aktionen, die z.B. das Kopieren und Ein-
fügen von ausgewählten Elementen veranlassen. Hilfe erhalten Sie mit
dem Help-Menü, das ganz rechts platziert ist und in der Abbildung
aufgeklappt ist. Zwischen den genannten Menüs befinden sich Einträ-
ge, deren Aufbau oder gar Vorhandensein vom aktuellen Fokus, aber
auch von den installierten Erweiterungen abhängig ist.
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Abb. 2-3

Die Menüzeile, in der

das Menü Help

ausgewählt ist

2.1.5 Werkzeugleiste

Unter der Menüleiste befindet sich standardmäßig die Werkzeugleiste.
Die Werkzeugleiste beinhaltet kleine Buttons, über deren Aktion ein
Symbol oder ein Tooltip Aufschluss gibt. Der Umfang der Aktionen ist
gegenüber der Menüleiste auf die am häufigsten ausgeführten beschnit-
ten, dafür können Sie diese schneller erreichen.

Die Buttons sind ihrer Funktion nach in Gruppen angeordnet, wo-
bei Sie die Position der einzelnen Gruppen über eine kleine vertikale
Leiste (engl. trim) innerhalb der Werkzeugleiste verändern können, ge-
gebenenfalls auch in weiteren Zeilen. In Abbildung 2-4 beispielswei-
se wurden die Gruppen in zwei Zeilen aufgeteilt. Einige Buttons der
Werkzeugleiste sind zusätzlich mit einem Dreieck versehen, das auf ein
Pulldown-Menü aufmerksam macht. Mit dessen Hilfe kann die Aktion
präzisiert werden. Beispielsweise bietet das Pulldown-Menü des New
C/C++ Project-Buttons ( ) die Möglichkeit an, ein neues C-Projekt
oder ein neues C++-Projekt anzulegen oder ein bereits existierendes
Eclipse-Projekt in ein C/C++-Projekt zu transformieren. Auch das kön-
nen Sie in der Abbildung sehen.

2.1.6 Statusleiste

Wie von anderen Programmen bekannt, befindet sich eine Statusleiste
im unteren Teil des Fensters, die beispielsweise für einen aktiven Editor
die aktuelle Zeilennummer angibt.

2.1.7 Editoren und Views

Der Hauptbereich der Oberfläche wird durch Editoren und sogenannteEditoren

Views beansprucht. Editoren werden, wie der Name schon sagt, haupt-
sächlich zum Bearbeiten von Quelltexten oder allgemeiner von Dateien
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Abb. 2-4

Buttons sind nach ihrer

Funktion gruppiert und

können Pulldown-

Menüs besitzen.

benutzt. Editoren befinden sich im Editorfeld, das in der Abbildung 2-
2 deutlich die zentrale Stelle einnimmt und pro Workbench höchstens
einmal vorkommt.

Demgegenüber dienen Views der Darstellung von spezifischen In- Views

formationen. Dazu zählen beispielsweise andere Darstellungsformen
des gerade in Bearbeitung befindlichen Quelltextes, wie es durch Out-
line-View realisiert ist und auf der rechten Seite der Abbildung zu se-
hen ist. Er gibt einen Überblick über definierte Funktionen und andere
Elemente. Ein View, der eine gänzlich andere Information anzeigt, ist
der Variables-View. Ihn werden Sie vor allen Dingen beim Debugging
nützlich finden. Auch die in der Abbildung links dargestellte Projekt-
hierarchie ist ein View oder, genauer gesagt, ein Vertreter der Navi-
gation-Views, die im Allgemeinen die hierarchische Organisation der
Ressourcen widerspiegeln.

Identifizierbar sind Editoren und Views immer anhand der Titel- Titelleiste

leiste, die wie die Fensterdekoration des Desktops in einem aktiven
und einem inaktiven Zustand gezeichnet werden kann. Ebenso ist vom
Desktop die Möglichkeit entlehnt, die Elemente per Drag’n’Drop über
ihre Titelleiste auf der Oberfläche verschieben zu können. Editoren dür-
fen Sie auf diese Weise ausschließlich in ihrem Bereich neben-, unter-
oder übereinander umstellen, wobei letztere Variante sicherlich die ge-
bräuchlichste ist. Bereiche mit überdeckenden Editoren haben dann die
Form eines Registerfelds, in dem die Registerkarten mit den geöffneten
Editoren korrespondieren. Dagegen lassen sich Views nur außerhalb
des Editorfelds platzieren, bieten Ihnen ansonsten aber mehr Möglich-
keiten der Positionierung. So können sie auch von der Workbench auf
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den Desktop gezogen werden, was sie in gewöhnliche Fenster verwan-
delt.

Abb. 2-5

View und Editor in

Gegenüberstellung. Die

Kontextmenüs können

durch einen Rechtsklick

auf die Titelleiste

hervorgebracht

werden.

Abbildung 2-5 stellt einen View einem Editor gegenüber. In beidenOperationen über der

Titelleiste Elementen sehen Sie ein Kontextmenü, das Sie durch einen Rechtsklick
über der jeweiligen Titelleiste hervorbringen können. Darüber ist es
möglich, die aus grafischen Benutzeroberflächen bekannten Operatio-
nen wie Minimieren, Maximieren und so weiter aufzurufen. Andere
Auswahlmöglichkeiten beschränken sich auf nur einen Typ. So können
Views zusätzlich vom Workbench-Fenster über das besagte Menü mit
Detached als eigenständige Fenster herausgelöst werden, was dem Her-
ausziehen des Views entspricht, oder in den Zustand Fast View überge-
hen.

Ein Fast View ist eine Art ikonifizierter View, dessen Symbol in einerFast View

speziellen Werkzeugleiste erscheint, die standardmäßig im unteren Teil
des Fensters ihren Platz findet. Ein ikonifizierter View wird bei Klick
auf sein Symbol dargestellt, verschwindet dann aber wieder, sobald ein
anderes Element aktiviert wird. Sinnvoll ist dieser Zustand für nur gele-
gentlich eingesehene Views. In besetzten Zustand können Sie die Leiste
in Abbildung 2-6 sehen. Dort sind gerade drei Views ikonifiziert: Out-
line, Navigator und Search. Mit dem Button Show View as a fast view,
über den der Mauszeiger gerade schwebt, können Sie die Liste ganz
flink um weitere noch nicht geöffnete Views ergänzen.

Abb. 2-6

Fast View-Leiste. Der

Navigator-View ist

gerade geöffnet.
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Zum Teil lassen sich die eben beschriebenen Funktionalitäten
auch mittels Tastatur herbeiführen. So können Sie beispielsweise mit
STRG+M den momentan aktiven View oder Editor maximieren – sehr
praktisch, wenn der der Workbench zur Verfügung stehende Platz recht
klein ist und Sie gerade Modifikationen am Quelltext vornehmen.

2.1.8 Perspektiven

Eclipse und CDT bieten eine Vielzahl von Views an, deren Umgang und
Nutzen wir im Laufe dieses Buches detailliert kennenlernen werden.
Häufig wird es so sein, dass der aktuelle Entwicklungsschritt andere
Informationen benötigt als ein folgender. Beispielsweise ist beim Editie-
ren von Quelltexten die bereits erwähnte Projekthierarchie interessant,
während diese Information speziell beim Debugging weniger von Nut-
zen ist. Beim Debugging hingegen möchten wir die Belegung aller im
Scope vorhandenen Variablen wissen. Mit dem Konzept der Perspek-
tiven bietet Eclipse die Möglichkeit, zwischen Ansichten verschiedener
Aufgabenbereiche schnell umzuschalten.

Abb. 2-7

Die Debug-Perspektive
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Eine Perspektive bestimmt das Layout der Eclipse-Workbench und
definiert zusätzlich mögliche Aktionen, die von Menü- und Werkzeug-
leiste in die Gänge gebracht werden können. Während z.B. in Abbil-
dung 2-2 die C/C++-Perspektive gezeigt wurde, zeigt im Unterschied da-
zu Abbildung 2-7 die Debug-Perspektive, eine der Debugging-Aufgabe
angepasste Benutzerschnittstelle. Geöffnet werden können Perspektiven
z.B., wie in Abbildung 2-8 dargestellt, nach Auswahl des Menüpunktes
Window > Open Perspective > Other.... Daraufhin erscheint das auf der
rechten Seite abgebildete Fenster, in dem alle vorhandenen Perspektiven
aufgelistet sind. Bereits einmal geöffnete Perspektiven lassen sich über
Shortcuts rechts oben in der Workbench abrufen. Mit dem Menüein-
trag Window > Close Perspective können Sie die aktuelle Perspektive
auch wieder schließen.

Abb. 2-8

Eine beliebige

Perspektive öffnen
Perspektiven können wahlweise in der gleichen Workbench umge-

schaltet werden oder in einem neuen Workbench-Fenster erscheinen.
Das Verhalten lässt sich in den Voreinstellungen, die über den Menü-
punkt Window > Preferences... zu erreichen sind, auf der Seite General
> Perspectives beeinflussen. Neben den durch die Plattform bereitge-
stellten Perspektiven ist es auch möglich, eigene Konfigurationen zu er-
stellen. Das aktuelle Layout lässt sich durch den Menüpunkt Window
> Save Perspective As... unter einem neuen Namen abspeichern und mit
Window > Customize Perspective... weiter anpassen. Insgesamt ist die
Benutzeroberfläche sehr flexibel, und fast jedes Detail lässt sich ändern.
Mehr darüber erfahren Sie in Abschnitt 2.6.
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2.2 Das erste Projekt

Dieser Abschnitt soll Ihnen einen Vorgeschmack auf die Arbeit unter
Eclipse und CDT geben, ohne auf Details oder gar spezielle Problem-
lösungen einzugehen. Es werden die wichtigsten Schritte anhand einer
kleinen Applikation beschrieben, die die Glieder der Fibonacci-Zahlen-
folge auf dem Bildschirm ausgibt. Sie werden anschließend in der Lage
sein, Ihre ersten eigenen Projekte mit CDT zu erstellen und zu warten.

2.2.1 Eclipse Setup

Für die C/C++-Entwicklung empfiehlt es sich generell, das in Eclipse Automatisches

Übersetzen

ausschalten

übliche automatische Übersetzen von Projekten, das beim Abspeichern
von Quelltexten aktiv wird, abzuschalten. Im Gegensatz zum Java-
Builder funktioniert der Build für C/C++-Projekte nicht inkrementell,
d.h., es wird mindestens die eine Datei, an der Sie eine Änderung vorge-
nommen haben, komplett neu übersetzt. Dies kann je nach Größe des
Projektes, der verwendeten Include-Dateien sowie der eingebundenen
externen Bibliotheken erhebliche Zeit in Anspruch nehmen und damit
den Arbeitsfluss beeinträchtigen. Mit Hilfe des Menüpunkt Project >
Build Automatically können Sie diese Funktion ein- oder abschalten.

Wenn nicht anders angegeben, finden die Interaktionen mit Eclipse Auf die

C/C++-Perspektive

wechseln

in der C/C++-Perspektive statt, die von CDT für das Entwickeln von
C/C++-Projekten eingerichtet wurde. Öffnen Sie diese bitte, falls sie
noch nicht sichtbar ist.

Jetzt stellt sich noch die Frage, woher CDT weiß, wo Compiler und Kann der Compiler

aufgerufen werden?die anderen Tools zu finden sind, die zu Beginn installiert wurden. CDT
benutzt für das Auffinden der Programme den Kommandosuchpfad,
der über die Umgebungsvariable PATH global definiert wird. Unter Win-
dows wird jedoch der Compiler nicht zwingend im globalen Komman-
dosuchpfad zu finden sein, wohingegen dies unter Linux eher üblich ist.
Sie können dies gleich einmal testen, indem Sie in einer Eingabeauffor-
derung das Kommando gcc eingeben. Wird der Befehl gefunden? Falls
ja, können Sie zum nächsten Abschnitt übergehen.

Ansonsten müssen Sie entweder der Umgebungsvariable PATH den Kommandosuchpfad

anpassenrichtigen Pfad hinzufügen; hier ist gegebenenfalls ein Neustart von
Eclipse erforderlich. Oder Sie gehen in den Eclipse-Voreinstellungen, die
über den Menüpunkt Window > Preferences hervorgerufen werden, auf
die Seite C/C++ > Environment, um die Variable ausschließlich für CDT
anzupassen, wie in Abbildung 2-9 zu sehen ist. Um in der Liste den Ein-
trag hinzuzufügen, klicken Sie auf den Button Add.... Im neuen Dialog
geben Sie bei Name den Text PATH ein und bei Value das Verzeichnis,
in dem sich das Programm gcc befindet. Verwenden Sie beispielswei-
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se Cygwin, dann setzt sich der Eintrag aus dem Root-Verzeichnis, für
das Sie sich bei der Cygwin-Installation entschieden haben, und \bin

zusammen. Beide Fenster schließen Sie mit Ok.

Abb. 2-9

Die Variable PATH

können Sie in den

Einstellungen für

Umgebungsvariablen

anpassen.

2.2.2 Ablauf

Im Rahmen des einführenden Beispiels benutzen wir in der Werkzeug-
leiste die Buttons

■ New C/C++ Project, um ein neues Projekt anzulegen,
■ New C/C++ Source File, um eine neue Quelldatei anzulegen,
■ Save, um Änderungen in einer Datei zu sichern,
■ Build, um das Projekt zu übersetzen,
■ Run, um das übersetzte Programm in Eclipse auszuführen, und
■ Debug, um das übersetzte Programm zu debuggen.

2.2.3 Ein neues Projekt anlegen

Wählen Sie im Popup-Menü des New C/C++ Project-Buttons in der
Werkzeugleiste den Eintrag C Project1. Daraufhin öffnet sich ein Wi-
zard, der Sie nach dem Namen des Projektes fragt. Wie in Abbildung 2-
10 dargestellt, geben Sie hier bitte fibonacci ein. Achten Sie darauf, dass

1Alternativ können Sie im Menü den Menüeintrag Project > New > C Pro-
ject... auswählen.
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bei Project types der Eintrag Executable hervorgehoben ist. Klicken Sie
dann auf Finish, um die Angaben zu bestätigen und den Wizard zu
schließen. Im C/C++ Projects-View sollte anschließend ein neues Pro-
jekt unter dem angegebenen Namen erscheinen.

Abb. 2-10

Wizard, um neue

C-Projekte anzulegen

2.2.4 Die Quelldatei erzeugen

Selektieren Sie im C/C++ Projects-View unser eben erstelltes Projekt
und klicken Sie in der Werkzeugleiste auf den Button New C/C++
Source File, woraufhin ein Fenster erscheint, das Sie zur Eingabe des
Ordners und des Namens auffordert. Stellen Sie sicher, dass bei Source
Folder der Name unseres Projektes, also fibonacci, zu finden ist, und
geben Sie bei Source File den Namen fibonacci.c an. Die Quelltext-
Datei wird angelegt, sobald Sie die Eingabe mit Finish bestätigen.

Es treten nun zwei sichtbare Veränderungen innerhalb der Work-
bench auf. Erstens erscheint im fibonacci-Projekt der Dateiname
fibonacci.c. Zweitens, und das ist viel auffälliger, wird das Editorfeld
nun durch einen Editor für die neue Datei belegt, wie Sie am Titel deut-
lich erkennen können. Darin enthalten ist ein Cursor, der uns blinkend
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zur Quelltexteingabe auffordern möchte. Seiner Aufforderung nachge-
hend geben Sie den folgenden Quelltext ein und behalten dabei den
Outline-View im Auge:

Listing 2.1

fibonacci.c

#include <stdio.h>

unsigned int fib(unsigned int n)

{

int i, f1=0, f2=1, f3;

if (n<2) return n;

for (i=2;i<=n;i++);

{

f3 = f1 + f2;
f1 = f2;

f2 = f3;

}

return f2;

}

int main(int argc, char *argv[])

{

for (i=0;i<10;i++)

printf("fib(%u)=%u\n",i,fib(i));

return 0;

}

Zwei sehr nützliche Funktionen von CDT werden Sie schon beim ersten
Eingeben des Textes bemerken:

1. Sobald Sie eine kleine Pause beim Eingeben machen, wird links
vom eigentlichen Texteditor an der richtigen Zeile ein Warnsym-
bol angezeigt, falls rein formal kein syntaktisch korrekter C/C++-
Quelltext vorliegt.

2. Der Outline-View, der die Struktur des Programms abbildet, passt
sich zügig der aktuellen Eingabe an.

Sobald Sie fertig sind, betätigen Sie den Button Save, den MenüpunktBenutzen Sie den

Button Save , um

die Datei zu sichern.

File > Save oder den Tastatur-Shortcut STRG+S, um die Datei abzu-
legen. Die Benutzeroberfläche sollte sich nun in der gleichen Ansicht
befinden, wie sie in Abbildung 2-11 zu sehen ist.



2.2 Das erste Projekt 41

Abb. 2-11

Die C/C++-Perspektive

mit geöffnetem

Quelltext-Editor. Der

Outline-View rechts

zeigt die Struktur des

Quelltextes an.

2.2.5 Übersetzen

Um das manuelle Übersetzen unseres Projektes zu starten, benutzen Sie
bei aktiviertem Projekt entweder den durch ein Hämmerchen symbo-
lisierten Build-Button aus der Werkzeugleiste oder den Menüpunkt
Project > Build Project. Daraufhin öffnet sich ein Fenster, das Sie über
den anstehenden Übersetzungsvorgang aufmerksam machen möchte.
Wenn Sie den Console-View zur Ansicht bringen2, werden Sie die auf-
gerufenen Compiler-Kommandos und ihre Ausgaben umgeben von ein
paar CDT-spezifischen Ausgaben erkennen können.

Bestimmt haben Sie es bei der Eingabe schon bemerkt, dass sich im
abgedruckten Quelltext ein Fehler eingeschlichen hat. Falls Sie diesen
übernommen haben, so macht Eclipse den Fehler gleich auf verschiede-
ne Arten deutlich, die in Abbildung 2-12 zu sehen sind.

2Wenn Sie diesen nicht finden, nutzen Sie bitte den entsprechenden
Menüeintrag unter Window > Show View oder die Tastenkombination
ALT+SHIFT+Q,C.
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Abb. 2-12

Hinweise auf Fehler

durch Marker und

Unterstreichungen Den deutlichsten Hinweis gibt dabei der Quelltexteditor selbst. Ein
roter Marker auf der linken Seite des Editors zeigt die Zeile an, bei der
der Compiler den Fehler vermutet. Führt man den Mauszeiger über den
Marker, so erscheint eine genaue Beschreibung, die in etwa

’i’ undeclared (first use in this function)

lauten sollte. Logisch, denn die Programmiersprache C erwartet die De-
klaration einer Variablen vor deren Benutzung. Das haben wir nicht
gemacht, und dieses Versäumnis wird zurecht vom Compiler moniert.
Wir fügen also vor die Schleife ein int i ein, speichern den Quelltext er-
neut ab und lassen den Compiler wieder seine Arbeit verrichten, indem
wir auf den entsprechenden Button klicken.

Dieses Mal sollten Fehlermeldungen durch den Compiler ausblei-
ben, die roten Marker also nicht mehr zu sehen sein. Eine weitere Än-
derung macht sich dann im C/C++-Project-View bemerkbar: Ein neu-
er besonders gekennzeichneter Ordner, der den Namen Binaries trägt,
zeigt an, dass im Projekt eine ausführbare Datei vorhanden ist. Durch
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Aufklappen des Ordners können Sie sich vergewissern, dass es sich tat-
sächlich um unsere Fibonacci-Applikation handelt.

2.2.6 Ausführen

Jetzt, wo alles nach Plan übersetzt wurde, wollen wir das Programm
einmal starten. Stellen Sie hierfür sicher, dass im C/C++-Projects-View
das Projekt fibonacci selektiert ist. Anschließend können Sie den Menü-
punkt Run > Run oder den durch ein Play-Symbol gekennzeichneten

Run-Button in der Werkzeugleiste nutzen, um das Programm auszu-
führen, wobei implizit der Übersetzungsprozess noch einmal angesto-
ßen wird.

Die Standardausgabe der ausgeführten Programme wird in den
Console-View umgeleitet. In unserem Fall sollte die Ausgabe

fib(0)=0

fib(1)=1

fib(2)=1

...

fib(9)=1

ähneln, was nicht genau dem erwarteten Ergebnis entspricht. Es ist also
gleich Zeit, sich dem Debugger zuzuwenden.

Zuvor inspizieren wir aber erneut die Konsolenausgabe. Wir kön-
nen darin erkennen, dass der Compiler mit der Option ­O2 aufgerufen
worden ist. Dies bedeutet, dass der Compiler den Code optimiert, was
eine denkbar schlechte Voraussetzung für eine quelltextbasierte Debug-
Session ist. Deshalb wollen wir zunächst die Optimierungsstufe des
Compilers ändern.

Hierzu benötigen wir die Project Properties unseres Projektes. Sie
bekommen Zugriff darauf, indem Sie im Kontextmenü des Projektord-
ners den Eintrag Properties auswählen. Zugleich erscheint ein neues
Fenster mit typischem Voreinsteller-Layout, d.h., links befinden sich
hierarchisch angeordnete Kategorien und rechts die konkreten Einstell-
möglichkeiten. Von der Menge der angebotenen Optionen soll an dieser
Stelle nur die Seite C/C++-Build > Settings interessieren und davon ganz
speziell die Auswahl Optimization der Registerkarte Tool settings; wie
in Abbildung 2-13 zu sehen, setzen wir sie auf None (-O0). Mit Klick
auf Ok akzeptieren wir die vorgenommene Einstellung.

2.2.7 Programmfehler aufspüren

Sie haben das Problem sicherlich schon beim Eingeben entdeckt oder
sich gar geweigert, den Quelltext in der gedruckten Form abzutippen.
Eventuell haben Sie auch unbewusst den Fehler nicht mit übernommen.
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Abb. 2-13

Optimierungs-

einstellungen. Um

Source-Level-Debug-

ging durchzuführen, ist

es sinnvoll, die durch

den Compiler

vorgenommenen

Optimierungen

gänzlich abzuschalten.

Wie dem auch sei, wir werden jetzt den Debugger zu Rate ziehen, um
dem kleinen Fehler, den wir bei der Konsolenausgabe bemerkt haben,
auf die Schliche zu kommen.

Um das Programm im Debug-Modus zu starten, benutzen Sie
den Debug-Button, der sich gleich neben dem Run-Button befindet
und stilecht durch einen Käfer gekennzeichnet ist. Abermals versucht
Eclipse, das Projekt zu übersetzen – dieses Mal jedoch mit der geänder-
ten Optimierungseinstellung.

Eclipse wird Sie nun fragen, ob Sie in die Debug-Perspektive schal-
ten möchten; bestätigen Sie diese Frage bitte. Wenn Sie die ebenfalls
angebotene Option Remember my decision aktivieren, werden Sie in
Zukunft gar nicht mehr gefragt. Nebenbei bemerkt können Sie diese
Entscheidung in den Run/Debug > Perspectives-Voreinstellungen unter
Open the associated perspective when an application suspends auch
wieder rückgängig machen.

Je nach verwendetem Compiler kann es unter dem Windows-Be-
triebssystem vorkommen, dass Eclipse den Quelltext nicht findet, da
CDT zu Beginn z.B. nichts von Cygwin-Pfaden zu wissen scheint. In
dem Fall haben Sie die Möglichkeit, den Quelltext mit Locate File...
auch für Eclipse auffindbar zu machen. Unter Linux sollten Sie derarti-
ge Probleme bei diesem Beispiel nicht haben.

Abbildung 2-14 zeigt den Aufbau der Workbench mit gestarteter
Debugging-Session auf. Im Unterschied zur C/C++-Perspektive nimmt
das Editorfeld in der standardmäßigen Einstellung deutlich weniger
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Abb. 2-14

Die erste

Debugging-Session

Platz ein. Der C/C++-Project-View mit seiner gesamten Projekthierar-
chie ist gänzlich verschwunden. Der dadurch entstandene Platz wird
durch zwei bisher geschlossene View-Felder ausgefüllt. Dabei ist der
hier überhaupt wichtigste View der Debugging-View, mit dem einige
Buttons assoziiert sind; durch sie kann der Ablauf des zu debuggen-
den Programm gesteuert werden. Im Quelltexteditor korrespondiert ein
blauer Pfeil zum aktuellen Wert des Befehlszählers der CPU (im Engli-
schen program counter oder instruction pointer), also eine Zeile mit
einer Anweisung, die als Nächstes ausgeführt werden soll. Zu Beginn
ist es die Zeile mit der ersten Anweisung gleich unter dem main()-Funk-
tionskopf.

Um den nächsten Schritt des Programms ausführen zu lassen, be-
nutzen wir den Button Step Over . Nach einem zweiten Schritt steht
der Befehlszähler auf der Zeile mit dem printf ()-Aufruf. Der Variables-
View wurde aktualisiert und zeigt für die Variable i den Wert 0. Wir
lassen das Programm weitere zwei Schritte laufen. Da die Ausgabe für
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i = 2 nicht stimmte, betätigen wir anschließend den Button Step In-
to , mit dessen Hilfe wir in Funktionen hineinspringen können.

Der Befehlszähler steht nun auf der ersten Zeile der Funktion fib().
Der Variables-View wurde an die sichtbaren Variablen angepasst. Wir
führen weitere Schritte aus und überprüfen dabei, ob das Ändern der
Variablen und der Kontrollfluss mit unseren Erwartungen übereinstim-
men. Wenn sich der Befehlszähler hinter dem Schleifenkopf befindet,
spätestens aber, wenn wir den Schleifenrumpf passiert haben, stellen
wir fest, dass die Schleife nicht ordnungsgemäß abgearbeitet wird. Ge-
nau genommen wird sie überhaupt nicht abgearbeitet. Bei sorgfältigem
Hinschauen ist der Übeltäter schnell erkannt: ein überflüssiges Semi-
kolon hinter der for-Anweisung. Ein sehr typischer Fehler, der immer
wieder auch von C-Entwicklern mit mehrjähriger Erfahrung gemacht
wird; der Autor schließt sich hier nicht aus.

Noch in der Debug-Perspektive entfernen Sie das Semikolon undBenutzen Sie den

Button Stop , um die

Ausführung zu

terminieren.

klicken auf den Button mit dem roten Stoppsymbol, um die Abarbei-
tung des Programmes zu terminieren. Anschließend sichern Sie die eben
durchgeführte Änderung, bevor das Programm wieder zur Ausführung
gebracht werden kann. Ein Klick auf den Run-Button in der Werkzeug-
leiste genügt dafür. Die Ausgabe im Console-View sollte jetzt tatsäch-
lich die bekannte Fibonacci-Zahlenfolge widerspiegeln.

2.2.8 Zusammenfassung und Ausblick

In diesem Abschnitt haben Sie erfahren, wie Sie mit Eclipse und CDT
neue Projekte anlegen können, haben erste Erfahrungen mit dem Edi-
tor gesammelt, einen kurzen Ausschnitt über die Arbeitsweise des
Build-Prozesses kennengelernt und unter Zuhilfenahme des Debuggers
einen Fehler aufgespürt. Auf Grundlage der vorgestellten Arbeitsschrit-
te könnten Sie, wenn Sie mögen, das Buch kurz beiseite legen und zu-
nächst Eclipse auf eigenem Wege erkunden.

Natürlich liegt der Teufel auch hier im Detail. Der Funktions-
umfang der IDE ist weitaus komplexer, ansonsten wäre das Buch
hier bereits zu Ende, und Sie würden sich wahrscheinlich ärgern. Für
den Rest des Buchs werden Schritt für Schritt die Möglichkeiten ver-
tieft, die Eclipse, CDT und andere Plugins Ihnen in Sachen C/C++-
Programmieren bieten. Um jedoch eine Vertrautheit gegenüber der
Plattform zu gewinnen, bedarf es neben dem Studium auch der prakti-
schen Anwendung. Hier können Sie die Zügel selbst in die Hand neh-
men und, ausgehend von den Beispielen, das Gelernte auf die eigenen
Problemstellungen transferieren. Dabei können Sie das Buch ruhig auch
mal zur Seite legen, denn Hilfestellungen, die bei einem solchen Erkun-
dungstrip vonnöten sind, vermag Ihnen auch Eclipse in verschiedenen
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Formen selbst zu geben. Auf die unterschiedlichen Facetten des Hilfe-
systems soll deswegen im folgenden Kapitel eingegangen werden.

2.3 Das Eclipse-Hilfesystem

Die Eclipse-Plattform kommt mit einem zentralen Hilfesystem daher.
Plugins, die einer Anleitung bedürfen, können sich in das System ein-
klinken und Ihnen ihre eigenen Inhalte anbieten. Auf diese Weise haben
Sie zudem den kompletten Überblick über alle auf Ihrem System einge-
richteten Plugins.

In diesem Abschnitt werden Sie erfahren, in welchen Situationen
Sie auf welche Weise die Hilfe aufrufen können.

2.3.1 Dokumentationsaufbau

Die oberste Ebene der Dokumentationshierarchie besteht aus den Plug-
ins, die eine Dokumentation beisteuern. Darunter sind dann die ein-
zelnen Punkte gegliedert. Die Gliederungsstruktur ist den Entwicklern
des Plugins prinzipiell freigestellt. Die Benutzer ansprechenden Doku-
mentationen haben jedoch häufig eine ähnliche Form, so dass Sie sich
in neuen Beschreibungen schnell zurechtfinden sollten. Die folgenden
Themen sind nahezu in jeder Dokumentation enthalten:

■ Getting started. Hier wird der Benutzer schnell in die Arbeitsschrit-
te für das Plugin eingeführt, häufig in Form von kleinen Tutorials.

■ Concepts. Diese Sektionen enthalten oft eine Übersicht über das
Plugin und klären über Konzepte, Begriffe und ihre Zusammen-
hänge auf.

■ Tasks. Hier werden konkrete Abläufe beschrieben.
■ References. Das ist die Referenz zum Plugin. Voreinstellungen so-

wie die Funktionsweisen von Editoren und Views werden erläutert.

Daneben gibt es noch Themen, zu denen keine Unterthemen existieren.
Diese sind häufig:

■ Tips and tricks, in denen sich problemorientierte Tipps finden,
■ What’s new, worin die Änderungen von einer vorherigen Version

des Plugins beschrieben sind, sowie
■ Legal, die Informationen bzgl. des Urheberrechts der Dokumenta-

tion beinhalten.
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2.3.2 Hilfefenster

Zugriff auf das Hilfesystem erhalten Sie, indem Sie den Eintrag Help >
Help Contents aus dem Menü auswählen. Eclipse zeigt darin ein zwei-
geteiltes Fenster, das Sie in Abbildung 2-15 sehen können. Als eines der
wenigen Fenster in Eclipse ist dieses nicht modal, d.h., Sie können in
anderen Eclipse-Fenstern weiterarbeiten, während die Hilfe dargestellt
wird, was sicherlich den Zweck einer Hilfe sehr begünstigt.

Abb. 2-15

Das Hilfefenster hat

einen Aufbau, der

typisch für ein

hierarchisches

Hilfesystem ist: links

die baumartige

Struktur, rechts der

Inhalt.

Auf der linken Seite ist die Struktur der Hilfe zu sehen. Durch Auf-
klappen von einzelnen Punkten können Sie durch die Dokumentation
baumartig navigieren. Der eigentliche Inhalt wird dann im großen Be-
reich Webbrowser-ähnlich auf der rechten Seite präsentiert, sobald Sie
ein Thema selektiert haben.
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Weitere Interaktionsmöglichkeiten bieten die Buttons, die sich ober- Aktionen der

Gliederungsübersichthalb der beschriebenen Bereiche befinden. Für die Gliederungsübersicht
wären dies

■ Show All Topics. Normalerweise werden in die Gliederung nur die-
jenigen Themen von Plugins aufgenommen, deren Komponenten
auch aktiviert sind (siehe Abschnitt 2.5.8). Wenn Sie diese Opti-
on aktivieren, so fließen tatsächlich alle möglichen Themen in die
Gliederung mit ein.

■ Print Topics. Hiermit können Sie die Themen ausdrucken. Sie ha-
ben die Wahl, das Thema mit oder ohne allen zugehörigen Unter-
themen auszudrucken.

■ Collapse All. Hiermit werden die geöffneten Gliederungspunkte ge-
schlossen.

■ Link with Contents. Falls Sie im rechten Teil durch die Benutzung
von Hyperlinks zu anderen Themen navigieren, so wird das ent-
sprechende Thema auch in der Übersicht sichtbar gemacht, falls
diese Option aktiviert ist.

Für den Fließtext stehen Ihnen neben den Browser-üblichen Naviga- Aktionen über den

Fließtexttions-Buttons Forward, Backward und Home noch weitere zur Verfü-
gung:

■ Show in Table of Contents, um die aktuelle Seite im Gliederungs-
verzeichnis wiederzufinden,

■ Print Page, um die dargestellte Seite zu drucken, sowie
■ Bookmark Document, um die aktuelle Seite zu den Hilfe-Fenster-

eigenen Lesezeichen hinzuzufügen.

Den Einblick auf die Lesezeichen finden Sie im Register Bookmarks, Zu den Lesezeichen

findendie Sie im linken unteren Bereich anwählen können. Ein Klick darauf
lässt die einfache Liste erscheinen, deren Elemente mit darüber gesetz-
ten Buttons gelöscht werden können.

Zusätzlich zu den Navigationsmöglichkeiten können Sie auch nach Nach Begriffen suchen

Begriffen suchen. Hierfür existiert ein Texteingabefeld im oberen Teil
des Fensters, in dem Sie auch die Joker-Zeichen »*« und »?«, die boole-
schen Ausdrücke »AND«, »OR« und »NOT« sowie Anführungszeichen
als Kennzeichen für zusammenhängenden Text benutzen können. Die
Ergebnisse werden dann in einem weiteren Register im linken Bereich
präsentiert.



50 2 Erste Schritte

Im Übrigen können Sie die Hilfe aller Eclipse-Projekte auch überDie Dokumentation

gibt’s auch im Netz. das »Weltweite Netz« unter der Adresse

http://help.eclipse.org

abrufen. Das Benutzerinterface der Webseite ist dem hier vorgestellten
ganz ähnlich. Die dort angebotene Dokumentation umfasst jedoch die
Texte aus dem gesamten Spektrum der harmonisiert veröffentlichten
Eclipse-Plugins des aktuellen Zyklus.

2.3.3 Kontextbezogene Hilfe

Neben der eben erläuterten statischen Hilfe, mit der Sie selbst gezielt
nach Informationen suchen können, kennt Eclipse noch das Konzept
der dynamischen oder kontextbezogenen Hilfe, die Sie für spezifische,
gerade in Betrachtung befindliche Elemente erhalten.

Die kontextbezogene Hilfe rufen Sie auf, indem Sie den Menüein-
trag Help > Dynamic Help auswählen oder F1 auf Ihrer Tastatur betäti-
gen. Daraufhin öffnet sich das in Abbildung 2-16 illustrierte Help-View,
falls es nicht schon zuvor geöffnet war.

Diese Art der Hilfe ist nicht nur für das Fenster der WorkbenchNutzen Sie das

Fragezeichen , um

kontextbezogene Hilfe

in Fenstern zu erhalten.

verfügbar, sondern auch für so manch andere Fenster. Signal hierfür ist
ein kleines Fragezeichen, das in den meisten Fällen im unteren linken
Teil des Fensters zu finden ist. Das Betätigen dieses Symbols oder der
F1-Taste lässt dann im rechten Teil die aus dem Help-View bekannte
Ansicht erscheinen.

Über die eingebetteten Hilfekomponenten haben Sie natürlich auch
auf die aus dem Hilfe-Fenster bekannte Funktionen Zugriff. Hierfür
dienen die Verknüpfungen, die sich unterhalb der Go To-Aufschrift be-
finden. Die Themen der statischen Hilfe erhalten Sie mit All Topics,
die Suchfunktion mit Search, den Index über Index und die Lesezei-
chen mit Bookmarks. Mit dem Punkt Relatic Topics schalten Sie die
kontextbezogene Hilfe wieder ein. Des Weiteren existieren die üblichen
Navigationsbuttons: Mittels Back- und Forward-Buttons können Sie
entsprechend dem Verlauf vor- oder zurückbewegen.

Die erwähnte Suchfunktion, die Sie auch über den MenüeintragHilfesystem

durchsuchen Help > Search erreichen, bietet Ihnen zur Suche gegenüber dem Hil-
fesystem ein weiteres Feature: Denn neben der Suche innerhalb aller
lokalen Hilfetexte können Sie auch in anderen Medien suchen. Vorga-
bemäßig wird beispielsweise auch das WWW durch die Suchmaschine
Google nach dem Begriff durchsucht. Kontrolle über dieses Feature ha-
ben Sie über den Search scope.
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Abb. 2-16

Kontextbezogene Hilfe.

Der im hier rechts

befindlichen Help-View

angezeigte Hilfetext

richtet sich nach dem

aktiven Editor oder

View.

2.4 Eclipse über die Tastatur steuern

Alle Aktionen sind in Eclipse über die Tastatur abrufbar. Dies trägt zum
einen der Barrierefreiheit Rechnung, zum andern sind häufig benutzte
Funktionen über Tastaturkürzel schneller zu erreichen.

Zugriff auf die Menüeinträge erhalten Sie mit F10 (oder über die
linke ALT-Taste unter Windows). Sie können durch das Menü mit den
Cursortasten navigieren und den Eintrag mittels RETURN bestätigen.
Oder Sie wählen die Einträge mittels des in seiner Beschriftung unter-
strichenen Buchstabens in Zusammenhang mit ALT aus. Das funktio-
niert auch für alle anderen Bedienelemente. Weitere wichtige Tasten-
kürzel, die die allgemeine Bedienung von Eclipse betreffen, werden in
Tabelle 2-1 dargestellt.

Eine Liste aller möglichen Tastaturkürzel können Sie über den
Menüeintrag Help > Key Assist... (STRG+SHIFT+L) einsehen. Die dort
aufgelisteten Einträge sind kontextbezogen: Nur die Kommandos, die
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Tab. 2-1

Wichtige Tastenkürzel Kürzel Funktion

Strg+F6 Editioren durchwandern

Strg+F7 Views durchwandern

Strg+F8 Perspektiven durchwandern

F10 Menüleiste aktivieren

Shift+F10 Kontextmenü für den aktuellen View

Ctrl+F10 Pulldown-Menü für den aktuellen View

F12 Editor aktivieren

Strg+M Aktuellen View/Editor maxi-/minimieren

momentan absetzbar sind, erscheinen dort. Das funktioniert sowohl für
Views und Editoren als auch für Eingabefelder in anderen Fenstern.

Die Tastaturkürzel sind nicht fest und können den eigenen Bedürf-
nissen angepasst werden. Eine Einführung hierfür wird noch in diesem
Kapitel in Abschnitt 2.6.3 gegeben. Die in diesem Buch verwendeten
Tastaturkürzel entsprechen allerdings den Vorgabewerten.

2.5 Nützliche Einstellungen

Dieser Abschnitt gibt eine Einführung in das Voreinstellungssystem von
Eclipse. Eclipse bietet hier eine besonders große Fülle an Möglichkei-
ten. Deshalb soll Ihnen zuerst das Konzept nähergebracht werden und
lediglich anhand von wenigen, aber nützlichen Einstellungen die Be-
dienung verdeutlicht werden. Einstellungen, die die Individualisierung
der Benutzerschnittstelle von Eclipse zum Gegenstand haben, werden
dann im nächsten Abschnitt behandelt. Darüber hinausgehende, wichti-
ge Voreinstellungen, insbesondere jene, die die Abläufe in der Program-
mierung betreffen, werden in den einzelnen Kapiteln an entsprechender
Stelle besprochen. Ansonsten gilt auch hier das Motto »Anschauen und
Ausprobieren«.

2.5.1 Voreinstellungsdialog

Die Voreinstellungen rufen Sie herbei, indem Sie den Menüpunkt Win-
dow > Preferences... auswählen. Daraufhin erscheint ein Fenster, das so
ähnlich aussehen sollte wie das in Abbildung 2-17 dargestellte. Links
befindet sich eine Auswahl von Kategorien, während Sie im rechten Teil
die zur selektierten Kategorie passenden Voreinstellungen vornehmen
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können. Mit Hilfe der Pfeile im oberen Bereich des Fensters können
durch bereits besuchte Kategorien navigieren.

Mitunter suchen Sie nach einer ganz bestimmten Kategorie. Hierfür
können Sie im Texteingabefeld, das sich über der Kategorieauswahl be-
findet, Titel sowie Schlüsselwörter eingeben, nach denen die dargebote-
nen Kategorien gefiltert werden. Wenn Sie beispielsweise Einstellungen
des Proxys verändern möchten, so geben Sie dort einfach proxy ein, so
dass die Auswahl von Kategorien erheblich schrumpft.

Abb. 2-17

Voreinstellungsfenster

2.5.2 Hierarchie der Voreinstellungen

Wie so alles in Eclipse ist auch die Struktur des Aufbaus der Voreinstel-
lungen alles andere als linear. Vielmehr sind Kategorien hierarchisch
angeordnet, um ein leichteres Auffinden von Einstellungen zu ermögli-
chen. Des Weiteren können sich auf diese Weise Plugins an beliebiger
Ebene einklinken und dort neue Kategorien erstellen. Folgende Oberka-
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tegorien werden im Voreinstellungsdialog bei einer Standardinstallation
für C/C++-Entwicklung präsentiert.

■ General. Hier finden Sie alle Einstellungen, die das allgemeine Ver-
halten und Aussehen der Workbench von Eclipse betreffen.

■ C/C++. Diese Voreinstellungen werden durch das CDT-Plugin hin-
zugefügt. Hier finden sich alle Einstellungen wieder, die speziell die
C/C++-Entwicklung betreffen.

■ Help. Auch das Verhalten der Hilfe kann mit Einstellungen beein-
flusst werden.

■ Install/Update. Hier können Voreinstellungen bezüglich des Instal-
lierens von weiteren Plugins und der Strategie ihrer Aktualisierung
vorgenommen werden.

■ Run/Debug. Das Starten und Debuggen von Programmen stellt in
Eclipse ein separates Konzept dar. Hier können Sie allgemeine Ein-
stellungen vornehmen, die größtenteils visueller Natur sind.

■ Team. Hier befinden sich die Einstellungen, die sich um die Versi-
onsverwaltung drehen. Die Versionsverwaltung spielt eine besonde-
re Rolle, wenn Projekte innerhalb eines größeren Teams entwickelt
werden. Sie wird in aller Ausführlichkeit in Kapitel 6 behandelt.

Daneben gibt es noch weitere Kategorien. Da Sie mit dem vollständigen
Eclipse SDK Java- sowie Plugin-Entwicklung betreiben können, finden
sich dort beispielsweise zusätzlich die Kategorien Ant, Java und Plug-
in Development wieder, die jedoch allesamt weniger interessant für die
C-/C++-Entwicklung sind.

2.5.3 Allgemeine Workspace-Einstellungen

Die Einstellungen, die das Verhalten des Workspace beeinflussen, befin-
den sich auf der Seite General > Workspace. Diese ist in Abbildung 2-18
dargestellt.

Eine Philosophie von Eclipse ist, dass ein sich in Entwicklung be-Automatisch bauen

findliches Projekt immer in kompilierter Fassung vorliegen soll. Hier-
für verantwortlich ist die Option Build automatically, die standardmä-
ßig aktiviert ist und das Bauen nach jeder auf dem Datenträger gespei-
cherten Änderung veranlasst. Auf diese Weise werden die Turnaround-
Zeiten der Entwicklung verkürzt, da der Programmierer schon bei klei-
nen Modifikationen sofort Feedback über eventuelle Übersetzungsfeh-
ler bekommt. Leider funktioniert dies nur vernünftig, wenn das Über-
setzen an sich flott vonstatten geht.

Werden Dateien außerhalb von Eclipse modifiziert, so müssen stan-Ressourcen

automatisch

auffrischen

dardmäßig die geänderten Ressourcen oder ihre Container manuell auf-
gefrischt werden. Zwar weist Eclipse bei der Prozessierung einer nicht
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Abb. 2-18

Ansicht der

Voreinstellungen des

Workspaceunter Eclipse veränderten Ressource auf diesen Zustand hin, doch kann
das anschließend notwendige manuelle Auffrischen den Arbeitsfluss
stören. Abhilfe schafft hier das Aktivieren der Option Refresh auto-
matically. Allerdings könnte dies zu einer allgemeinen Beeinträchtigung
der Workbench-Performanz führen, insbesondere dann, wenn sich viele
Ressourcen im Workspace befinden.

Mit der Option Save automatically before build können Sie in Automatisch speichern

Eclipse veranlassen, dass die Änderungen aller Ressourcen, die von Ih-
nen gerade bearbeitet werden, vor dem Bauen eines Projekts auch auf
den Datenträger geschrieben werden.

Weiter unten spezifizieren Sie in Workbench save interval die Zeit Periodisch speichern

in Minuten, nach der der momentane Zustand des Workspace gesichert
wird.
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Innerhalb eines Workspace können Projekte andere Projekte refe-Referenzierte Projekte

renzieren, was zum Beispiel sinnvoll ist, wenn Header-Dateien oder Bi-
bliotheken geteilt werden. Des Weiteren können Sie Projekte schließen,
wenn Sie von Ihnen gerade nicht bearbeitet werden müssen. Wenn Sie
ein geschlossenes Projekt erneut öffnen, können im Kasten Open refe-
renced projects when a project is opened verschiedene Verhaltensweisen
angegeben werden. Referenzierte Projekte werden

■ geöffnet, wenn Sie Always angeben, oder
■ nicht geöffnet, wenn Sie Never selektieren. Alternativ werden Sie

bei jedem Öffnen
■ gefragt, wenn Sie Prompt angeben.

Das gleiche Schema finden Sie auch bei anderen Voreinstellungen wie-
der, etwa auf der Seite Run/Debug > Launching.

In den beiden untersten Kästen geht es um die Kodierung der aufTextkodierungen

Datenträger gesicherten Texte. Während in Text file encoding die Ko-
dierung für sichtbaren Text spezifiziert wird, wird durch New text fi-
le line delimiter ausschließlich die Kodierung für den Zeilenabgrenzer
angegeben. Beide Einstellungen haben keine Auswirkungen auf bereits
vorhandene Texte, so dass sie eigentlich nur bei einem neuen Workspace
modifiziert werden sollten, wenn der Bedarf überhaupt besteht.

2.5.4 Starten und Beenden

Attribute, die den Start und das Beenden von Eclipse zum Gegenstand
haben, können Sie auf der Seite General > Startup and Shutdown ver-
ändern. Das Interface wird in Abbildung 2-19 gezeigt.

■ Prompt for workspace on startup. Wenn diese Option aktiv ist,
erscheint beim Start von Eclipse der Workspace-Selektor.

■ Refresh workspace on startup. Schalten Sie diese Option ein, wenn
Sie wünschen, dass der Workspace bei jedem Programmstart aufge-
frischt wird.

■ Confirm exit when closing last window. Bei aktivierter Option müs-
sen Sie das Beenden von Eclipse bestätigen, das beim Schließen des
letzten Fensters erfolgen würde.

In der sich darunter befindlichen Liste Plug-ins activated on startup
werden Plugins aufgezählt, die beim Start von Eclipse gestartet werden.

2.5.5 Netzwerkeinstellungen

Mit den Netzwerkeinstellungen wurden Sie bereits in Abschnitt 1.7.1
konfrontiert, falls Sie CDT mit Hilfe der Funktion Software Updates...
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Abb. 2-19

Voreinstellungen, die

das Starten und

Beenden von Eclipse

betreffen

installiert haben. Zusätzlich zu der Aktualisierungsfunktion von Eclipse
greifen auch andere Plugins auf die Einstellungen zurück, wie z.B. die
Subversion-Unterstützung. Hauptsächlich bedürfen sie einer Änderung,
wenn Sie keine direkte Internet-Verbindung haben, sondern nur über
einen Proxy auf die Ressourcen des Internets zugreifen können. In Ab-
bildung 2-20 haben Sie die Ansicht der Voreinstellung noch einmal dar-
gestellt.

Netzwerkeinstellungen werden Workspace-übergreifend im Ver-
zeichnis configuration abgelegt. Das bedeutet, wenn Sie einen neuen
Workspace anlegen, so müssen Sie die Einstellungen nicht erneut vor-
nehmen, was auch ziemlich sinnvoll ist.

2.5.6 Einstellungen für SSH-Client

Das Eclipse-Framework besitzt einen integrierten SSH2-Client, der z.B.
von der CVS-Unterstützung, aber auch von anderen externen Plugins
verwendet werden kann. Einstellungen für diesen nehmen Sie auf der
Seite General > Network Connections > SSH2 vor. Auf der Seite befin-
den sich drei Register, von denen Sie zwei in Abbildung 2-21 vorfinden.

Im ersten Register gibt’s ganze zwei allgemeine Einstellungen vorzu-
nehmen. Zum einen das Verzeichnis der SSH2-Schlüssel (SSH2-Home),
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Abb. 2-20

Netzwerkeinstellungen

Abb. 2-21

SSH2-Einstellungen



2.5 Nützliche Einstellungen 59

zum anderen die privaten Schlüssel (Private keys), die bei der Initiali-
sierung der Verbindung benutzt werden sollen.3

Eine komfortable Möglichkeit, ein neues Schlüsselpaar zu erzeu-
gen, wird gleich im Register Key Management geboten. Mit den oberen
Buttons können Sie ein neues DSA- oder ein neues RSA-Schlüsselpaar
generieren lassen sowie bereits vorhandene Schlüssel laden. Gleich un-
ter den Buttons befindet sich ein Textfeld, in dem sich der öffentliche
Teil des aktuellen Schlüsselpaars befindet. Den Inhalt gilt es der Da-
tei authorized_keys des Zielrechners hinzuzufügen, die sich dort für ge-
wöhnlich ausgehend vom Heimatverzeichnis im Verzeichnis .ssh befin-
det. Ganz einfach geht das per Klick auf den Button Export Via SFTP...,
woraufhin nach Angabe des Zielrechners und Login der Schlüssel in die
Datei ohne weiteres Zutun eingefügt wird. Den privaten Schlüssel kön-
nen Sie schließlich mit dem Button Save Private Key... auf Ihren lokalen
Rechner bannen. Auf Wunsch können Sie den Zugriff auf den Inhalt
zusätzlich durch eine Passphrase sichern, die Sie dann unter Passphrase
und Confirm passphrase einzugeben haben.

2.5.7 Passwortspeicher

Nicht immer möchte man das Passwort neu eingeben. Deswegen bietet
Eclipse einen Passwortspeicher an. Damit die Sicherheit nicht allzu sehr
in Mitleidenschaft gezogen wird, wird ein Master-Passwort benutzt, um
den Passwortspeicher zu verschlüsseln. Dessen Eigenschaften können
Sie auf der Voreinstellungsseite General > Security > Security Storage
modifizieren.

2.5.8 Komponenten (de-)aktivieren

Wenn Sie in Version 3.4 von Eclipse das Set der installierten Featu-
res modifizieren, so hat das Auswirkungen auf alle in diesem Kon-
text gestarteten Instanzen von Eclipse, unabhängig davon, auf welchem
Workspace diese operieren. Dies ist nicht immer erwünscht. Befinden
sich in einem Workspace ausschließlich C/C++-Projekte, so benötigen
Sie das JDT-Plugin für Java-Projekte dort wahrscheinlich nicht. Sofern
dies von den Plugins unterstützt wird, können Sie einzelne Komponen-
ten aber im Kontext eines Workspace abschalten.

Hierfür bietet die Seite General > Capabilities in den Voreinstellun-
gen diverse Möglichkeiten, deren Ansicht in Abbildung 2-22 dargestellt
wird. Präsentiert wird die Liste Capabilities, die alle Kategorien von
Komponenten auflistet. Mit der vorangestellten Auswahlbox legen Sie
fest, ob diese Komponente im Workspace aktiviert sein soll oder nicht.

3Dem Gegenpart müssen entsprechende öffentliche Schlüssel bekannt sein.
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Entfernen Sie beispielsweise das Häkchen vor Team, so wird Eclipse
nicht mehr in der Lage sein, mit CVS oder ähnlich eingeordneten Ver-
sionierungssystemen umzugehen.

Abb. 2-22

Einstellungen der

aktiven Komponenten

Eine feinkörnigere Auswahl über die Komponenten erhalten Sie,
wenn Sie den Button Advanced... anklicken. Dann werden die bisher
angezeigten Komponenten weiter unterteilt. Sie könnten damit z.B. die
CVS-Unterstützung ausschalten, während andere Versionierungssyste-
me noch aktiv blieben. Auch könnten Sie die Java-Unterstützung ex-
plizit deaktivieren, da auch JDT dieses Ausschalt-Feature unterstützt.
Leider finden derzeit nur wenige andere Komponenten ihren Weg in
diese Voreinstellung. So wird auch CDT noch nicht dort aufgelistet.
Das bedeutet, dass dessen Aktivität auf diese Weise derzeit noch nicht
beeinflusst werden kann.
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2.6 Die Benutzerschnittstelle anpassen

Zum Abschluss des Kapitels und des ersten Teils des Buchs erfahren Sie
noch, welche Möglichkeiten bestehen, die Oberfläche an Ihre eigenen
Wünsche anzupassen. Hier werden bedienungsrelevante und auch ein
wenig kosmetische Einstellungen besprochen, mit denen Sie beispiels-
weise auch das Layout der Workbench festlegen können. Falls Sie mit
der Ansicht, die Eclipse Ihnen bietet, im Großen und Ganzen zufrieden
sind, können Sie diesen Abschnitt auch überspringen.

2.6.1 Werkzeug- und Menüleiste anpassen

Die Werkzeugleiste wird immer im oberen Teil unter der Menüleiste
dargestellt. Von dieser Restriktion einmal abgesehen, können Sie die
Symbole der Leiste nach Belieben anordnen, auch auf mehrere Zei-
len umspannende Weise. Oder Sie lassen sie mit dem Kontextmenü-
eintrag Hide Toolbar gänzlich verschwinden. Wenn das einmal passiert
ist, können Sie dies mit dem Menüeintrag Window > Show Toolbar
auch wieder rückgängig machen.

Aktionen, die über Menü- und Werkzeugleiste aufrufbar sind, hän-
gen von der dargestellten Perspektive ab. Im Allgemeinen ist die Aus-
wahl durch den Anbieter des zur Perspektive zugehörigen Plugins sinn-
voll vorgegeben. Sie kann von Ihnen aber auch modifiziert werden.
Hierfür wählen Sie den Menüeintrag Window > Customize Perspec-
tive..., woraufhin sich ein neues Fenster öffnet, das aus zwei Registern
besteht, die im Folgenden beschrieben werden.

Shortcut

Das Register Shortcut hat das in Abbildung 2-23 gezeigte Aussehen.
Hier können Sie bestimmen, welche Einträge in den Shortcuts der
Workbench erscheinen. Derzeit existieren drei Menüpunkte, die Short-
cuts aufnehmen können. Das wären:

■ New. Das Menü Project > New, um eine neue Ressource anzulegen.
■ Open Perspective. Das Menü Window > Open Perspective, um eine

Perspektive zu öffnen, das auch über den Button links neben den
bereits geöffneten Perspektiven verfügbar ist.

■ Show View. Das Menü Window > Show View, um einen View zu
öffnen. Auch das Menü Show View as fast view, das sich standard-
mäßig in der Workbench links unten in der Statusleiste befindet,
beinhaltet die ausgewählten Shortcuts.
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Abb. 2-23

Das Register Shortcut

Links im Register werden in einem Baum die unterschiedlichen Ka-
tegorien präsentiert, in die die Shortcuts thematisch eingeteilt werden
können. Das Auswählen einer Kategorie lässt einzelne Elemente in der
rechten Tabelle erscheinen. Aktivieren Sie dort die Elemente, die als
Shortcuts im gewählten Untermenü fungieren sollen.

Commands

Das Register Commands ist in Abbildung 2-24 dargestellt. Hier wird
festgelegt, welche Kommandogruppen in der Perspektive verfügbar
sind. Eine Kommandogruppe umfasst dabei Aktionen, die zu der glei-
chen Kategorie passen, und kann Aktionen für das Hauptmenü (mittle-
re Tabelle) oder Aktionen für die Werkzeugleiste (rechte Tabelle) bein-
halten.
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Abb. 2-24

Das Register

Commands

In der linken Tabelle werden alle verfügbaren Gruppen dargestellt.
Selektieren Sie ein Element, so zeigen die anderen beiden Tabellen an,
wie sich die Kommandogruppe manifestiert. Wenn Sie diese Grup-
pe dann mit Hilfe des Häkchens aktivieren, dann werden die Kom-
mandos der Perspektive tatsächlich hinzugefügt. So hätte eine aktivier-
te Kommandogruppe C/C++ Navigation zur Folge, dass die Einträge
Open Element..., Open Type in Hierarchy... und Open Element in Call
Hierarchy... im Workbench-Menü Navigate erscheinen und der Button
Open Element in der Werkzeugleiste erscheint.

2.6.2 Perspektiven verwalten

Neben den bereits vorgefertigten Perspektiven, die durch Plugins dem
Eclipse-Framework hinzugefügt werden, können Sie beliebig viele eige-
ne Perspektiven mit eindeutigen Namen erstellen. Hierfür wählen Sie
den Menüeintrag Window > Save Perspective As... aus, woraufhin ein
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Fenster eine Auswahl aller vorhandenen Perspektiven präsentiert und
zusätzlich ein Eingabefeld für einen Namen anbietet.

Wählen Sie im Fenster einen neuen Namen, so wird eine neue Per-Perspektiven anlegen

oder überschreiben spektive unter diesem Namen angelegt; ansonsten wird eine bereits
existierende Perspektive überschrieben. Abgespeichert werden die üb-
lichen Parameter einer Perspektive, d.h. welche Views geöffnet sind,
welche Positionen sie in der Workbench einnehmen und über welche
Kommandos verfügt werden kann. Das Symbol einer neuen Perspektive
entspricht im Übrigen dem Symbol der Perspektive, aus der sie hervor-
geht.

Möchten Sie eine Perspektive löschen, so kommen Sie mit diesemPerspektiven entfernen

oder wiederherstellen Vorhaben über die Voreinstellungen auf der Seite General > Perspec-
tives weiter. Klicken Sie die zu löschende Perspektive in der Liste an
und anschließend auf Delete. Es können allerdings nur selbst erstellte
Perspektiven gelöscht werden. Wünschen Sie dagegen den Ursprungszu-
stand einer überschriebenen Perspektive wiederherzustellen, so benut-
zen Sie den Button Reset, wenn diese Perspektive angewählt ist.

2.6.3 Tastatursteuerung anpassen

Eclipse lässt sich komplett über die Tastatur steuern. Dabei sind die
Tastenkürzel frei von Ihnen definierbar. Hierzu bedienen Sie sich in den
globalen Voreinstellungen der Seite General > Keys. Diese ist in Abbil-
dung 2-25 dargestellt.

Den größten Teil der Seite beansprucht eine Liste, in der alle Kom-
mandos (Spalte Command), ihre aktuelle Zuordnung auf der Tastatur
(Spalte Binding), in welchem Kontext sie gültig sind (Spalte When) und
ihre Kategorie (Spalte Category) aufgezeigt werden. Die letzte Spalte
User gibt an, ob Sie an diesem Eintrag Änderungen durchgeführt haben
(angezeigt durch ein U) und wenn ja, ob es sich dabei um einen Konflikt
handelt (angezeigt durch ein C). Ein Konflikt tritt dann auf, wenn ein
und dasselbe Tastenkürzel im gleichen Kontext zwei unterschiedlichen
Kommandos zugewiesen worden ist.

Die Liste ist insgesamt sehr groß, bietet aber die Möglichkeit, Ein-
träge nach den Spalten zu sortieren. Viel wirkungsvoller ist freilich der
Filter, der mit Hilfe des über der Liste befindlichen Texteingabefeldes
angegeben wird und nur diejenigen Elemente anzeigt, die irgendwo die
eingegebene Zeichenkette enthalten.

Wenn Sie einen Eintrag in der Liste anklicken, dann können Sie
Änderungen an diesem Kommando durchführen. Zunächst erscheint in
Description eine kurze Beschreibung des Kommandos. In Binding spe-
zifizieren Sie dann das Tastenkürzel, bei dessen Betätigung das selek-
tierte Kommando ausgeführt werden soll. Dieses Feld ist kein gewöhn-
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Abb. 2-25

Tastatursteuerung

anpassen. Dargestellt

ist die Voreinstellungs-

seite ohne Auswahl.

liches Texteingabefeld, sondern beantwortet Ihre Eingaben mit einer
Beschreibung der gedrückten Taste.

Über den Filter sehen Sie noch eine Auswahlbox, die den Titel Sche-
me trägt. Darunter verbergen sich vordefinierte Zuweisungen von Tas-
taturkürzeln der Kommandos. Diese sind nach Eclipse-Art selbstver-
ständlich nicht fest in ihrer Anzahl: Plugins können weitere Schemata
hinzufügen. So haben Sie als C/C++-Entwickler mindestens die Aus-
wahl zwischen

■ Default,
■ Emacs und
■ Microsoft Visual Studio.
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Letzeres Schema ist freilich vom C/C++-Plugin hinzugefügt worden und
passt die Tastatursteuerung an eine Microsoft Visual Studio ähnliche
Variante an.

2.6.4 Erscheinungsbild

Zum Abschluss des ersten Teils sollen noch ein paar Worte über die
kosmetische Flexibilität von Eclipse verloren werden. Hier ist die Vor-
einstellungsseite General > Appearance der Ausgangspunkt. Die mögli-
chen Optionen sehen Sie in Abbildung 2-26.

Abb. 2-26

Erscheinungsbild

ändern

Im oberen Bereich der Seite können Sie das Look and Feel der
Workbench festlegen und damit letztendlich das Aussehen der Edito-
ren und Views bis hin zu ihren grundsätzlichen Bedienungsweisen be-
einflussen. Die Auswahlbox Current presentation hält hierfür Einträge
aller verfügbaren Skins bereit. Da das Aussehen von Eclipse über die
Jahre stetigen Veränderungen unterworfen war, werden standardmäßig
neben der bereits bekannten Präsentation lediglich solche Skins ange-
boten, die Eclipse ein Aussehen aus früheren Zeiten verleihen.
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Wenn Sie die Option Override presentation settings aktivieren,
können Sie einige Parameter des ausgewählten Skins überschreiben.
Diese betreffen die Positionen der Tabs und der Knöpfe für geöffnete
Perspektiven.

Im unteren Bereich können Sie unter Current theme ein Themenset
auswählen und damit Farben und Zeichensätze für verschiedene Arten
von Ausgaben bestimmen. Im Detail können Sie diese in der unterge-
ordneten Einstellungsseite Color and Fonts anpassen.

■ Show traditional style tabs. Lässt Sie das Erscheinungsbild der Tabs
auf eine weniger geschwungene Form einstellen.

■ Enable animations. Das Öffnen und Verstecken von Views wird
animiert.

■ Enable colored labels. Wenn diese Option aktiviert ist, dann er-
scheinen Einträge in Listen und Bäumen farbig, um bestimmte In-
formationen besonders hervorzuheben. Auf welche Weise dies ge-
schieht, können Sie ebenfalls in Color and Fonts einstellen. Ge-
brauch von farbigen Einträgen machen der Search-View, Text-
Dekorationen und viele andere Elemente.

In der Tat können sich auch in dieses System Plugins einhängen und Skin-Plugins

weitere Präsentationen hinzufügen. Als Beispiel sei hier das Extended
VS Presentation-Plugin erwähnt, das versucht, das Feeling von Visu-
al C++ auf Eclipse zu übertragen4. Dessen Heimatseite ist unter der
Adresse

http://andrei.gmxhome.de/skins/index.html

zu finden. Die Update-Site lautet:

http://andrei.gmxhome.de/eclipse/.

Nachdem die Installation des Plugin erfolgreich abgeschlossen ist, er-
scheint in der Auswahlbox unter Current presentation der neue Eintrag
Extended VS Presentation. Einen Eindruck von dem Aussehen können
Sie sich anhand Abbildung 2-28 machen.

2.7 Verzeichnislayout auf dem Datenträger

Dieser Abschnitt möchte Ihnen die Inhalte und Organisationsstruktur
der Verzeichnisse näherbringen, die bei der Entwicklung unter Eclipse
eine Rolle spielen. Idealerweise sollten Ihnen – als Anwender von
Eclipse – die meisten der hier vorgestellten Details verborgen bleiben

4Ob so etwas wirklich sein muss, ist freilich Geschmackssache.



68 2 Erste Schritte

Abb. 2-27

Eclipse im alten

Gewand

und deshalb zunächst kaum von Interesse sein. In der Realität kom-
men Sie jedoch nicht um ein tieferes Verständnis herum, denn Eclipse
selbst ist eine äußerst komplexe Software, die, obwohl ausgiebig getes-
tet, Ihnen ab und zu Probleme bereiten wird, zum Beispiel in Form von
Abstürzen. Jegliches Hintergrundwissen über die systemnahe Struktur
kann Ihnen dabei helfen, zumindest die Ursachen für ein Problem zu
finden oder in zweiter Instanz dieses zu beheben.

Wichtige Verzeichnisse sind dabei das Programmverzeichnis sowie
die Verzeichnisse der Arbeitsbereiche. Im Folgenden wird auf deren Be-
deutung und deren Handhabung eingegangen.

2.7.1 Programmverzeichnis

Das Programmverzeichnis ist dasjenige, das Sie nach dem Entpacken
des heruntergeladenen Eclipse-Archivs vorliegen haben. Sie wissen be-
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Abb. 2-28

Eclipse mit dem Visual

Studio Theme

reits, dass das Verzeichnis je nach Betriebssystem die Dateien eclipse

oder eclipse.exe beinhaltet. Am Anfang des Buchs wurden sie als
Eclipse Program Launcher bezeichnet. Sie wissen auch bereits über die
Datei eclipse.ini Bescheid, mit deren Hilfe Sie den Start von Eclipse
beeinflussen können. Zusätzlich verbergen sich freilich noch weitere
Dateien oder Verzeichnisse darin, die für Sie in Abbildung 2-29, einem
Screenshot vom Windows Explorer, aufgelistet werden.

Verzeichnis: configuration

Hier werden die in Eclipse vorgenommenen Einstellungen in Form von
Konfigurationsdateien abgelegt. Bequemerweise werden die Dateien im
ASCII-Format ausgeschrieben, so dass sie in jedem beliebigen Editor
angezeigt oder gegebenenfalls modifiziert werden können. Allerdings
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Abb. 2-29

Die Ansicht des Pro-

grammverzeichnisses

nach dem Entpacken landen in diesem Verzeichnis nur Workspace-übergreifende Einstellun-
gen, wie z.B. die der Netzwerkeinstellungen.

Von besonderer Bedeutung ist die Datei bundles.info, die im Unter-
verzeichnis org.eclipse.equinox.simpleconfigurator lokalisiert ist. Dar-
in werden alle während des Programmstarts zu aktivierenden Plugins
aufgezählt. Sie sollten an ihr nur im Notfall Hand anlegen, da Sie von
Eclipse – oder besser von p2 – verwaltet wird.

Verzeichnis: dropins

Dieses Verzeichnis gehört zu den überwachten Verzeichnissen (engl.
watched directory). Überwachte Verzeichnisse werden beim Start von
Eclipse eingelesen, um nach noch nicht eingerichteten Features und
Plugins Ausschau zu halten, die dann dem System hinzugefügt werden.
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Verzeichnis: p2

Das Verzeichnis enthält die sogenannte Profil-Registry, in der alle aktu-
ellen Installationen aufgelistet sind.

Verzeichnis: plugins

In diesem Verzeichnis befinden sich sämtliche Plugins. Nahm dieses Ver-
zeichnis vor Version 3.4 auch manuell hinzugefügte Plugins auf, so ist
dies jetzt eigentlich tabu. Das Konzept des dropins-Verzeichnis ist das
weitaus flexiblere, da es eine saubere Trennung von benutzerhinzuge-
fügten Plugins und standardmäßig vorhandenen Plugins erlaubt.

Verzeichnis: features

Ein Feature fasst Plugins, die vom selben Anbieter sind und sich zu
einem Werkzeug ergänzen, zu einer in Eclipse verwaltbaren Einheit zu-
sammen. Verwaltbar bedeutet, dass diese installiert oder deinstalliert
werden können. Features können auch an Voraussetzungen gebunden
sein, z.B., dass die Präsenz eines anderen Features gefordert wird. Die
Infrastruktur in Form von Ressourcen landet in diesem Verzeichnis.
Wie beim plugins-Verzeichnis ist es ab Eclipse 3.4 tabu, manuell Hand
anzulegen.

Verzeichnis: readme

Hier finden Sie Copyright-Informationen oder Ähnliches von Eclipse
und weiteren Plugins.

Sonstige Dateien

Neben den bereits vorher erwähnten Dateien eclipse.ini und dem
Eclipse Program Launcher finden Sie auf einer Windows-Installation
die Datei eclipsec.exe im Programmverzeichnis vor. Diese sollten Sie
anstelle von eclipse.exe benutzen, wenn Sie Eclipse über die Windows-
Kommandozeile zu starten wünschen. Damit funktionieren dann auch
Dateiumleitungen, wenn Eclipse in die Standardausgabe schreibt.

2.7.2 Workspace

Das Workspace-Verzeichnis ist das Verzeichnis, in dem Eclipse alle be-
nutzerrelevanten Daten ablegt. Zum einen sind das natürlich die Pro-
jekte, deren von Ihnen angelegte Struktur dort eins zu eins abgebildet
wird. Zum anderen existiert ein Verzeichnis mit Namen .metadata.
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Die Datei .metadata/log beispielsweise enthält alle geloggten Aus-log

gaben vom Eclipse-Framework. Sollte es schwerwiegende Probleme wie
Abstürze in Eclipse geben, so ist das der wohl am besten geeignete Ort,
um mit der Ursachenforschung zu beginnen.




